VS:GetTexSpaceOrigin

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexSpaceOrigin returns the offset of the referenced texture space that takes coordinates from world space to texture space.

PROCEDURE GetTexSpaceOrigin(
textureSpace :HANDLE;
VAR offsetX,offsetY,offsetZ :REAL);
def vs.GetTexSpaceOrigin(textureSpace):
    return offset

Parameters

textureSpace HANDLE Handle to texture space.
offset REAL Returns texture space offset value.

Remarks

Returns the offset that takes coordinates from world space to texture space

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks8.0