VS:GetTexSpaceOrientV

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexSpaceOrientV returns the vector that describes the v-axis of the referenced texture (from world space to texture space).

PROCEDURE GetTexSpaceOrientV(
textureSpace :HANDLE;
VAR vXAxis :REAL;
VAR vYAxis :REAL;
VAR vZAxis :REAL);
def vs.GetTexSpaceOrientV(textureSpace):
    return (vXAxis, vYAxis, vZAxis)

Parameters

textureSpace HANDLE Handle to texture space.
vXAxis REAL Returns v-axis vector X component.
vYAxis REAL Returns v-axis vector Y component.
vZAxis REAL Returns v-axis vector Z component.

Remarks

Returns the vector that describes the v-axis of the texture (from world space to texture space)

Version

Availability: from VectorWorks8.0