VS:GetTexSpaceKind

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpaceKind returns the object type for texture mapping space.

Table - Texture Mapping Spaces
Date Style Constant
Plane 0
Sphere 1
Cylinder 2
Algorithmic 3
FUNCTION GetTexSpaceKind(
textureSpace :HANDLE) : INTEGER;
def vs.GetTexSpaceKind(textureSpace):
    return INTEGER

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

Returns the kind of the texture mapping space; 0 = Plane space, 1 = Sphere, 2 = Cylinder, and 3 = Algorithmic (Perimeter or Roof)

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0