VS:GetTexSpaceKind

From Vectorworks Developer
Revision as of 10:17, 29 December 2017 by CBM-c- (talk | contribs) (fix)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpaceKind returns the object type for texture mapping space.

Table - Texture Mapping Spaces
Date Style Constant
Plane 0
Sphere 1
Cylinder 2
Algorithmic 3
FUNCTION GetTexSpaceKind(
textureSpace :HANDLE) : INTEGER;
def vs.GetTexSpaceKind(textureSpace):
    return INTEGER

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

(Orso, 2018 Dec. 29) Use VS:GetTexMapIntN instead.


Returns the kind of the texture mapping space; 0 = Plane space, 1 = Sphere, 2 = Cylinder, and 3 = Algorithmic (Perimeter or Roof)

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0