VS:GetTexSpaceKind: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand info)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 49: Line 49:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use [[VS:GetTexMapIntN]] instead.  
[[User:CBM-c-|_c_]], (2018.12.29) Use [[VS:GetTexMapIntN]] instead.  





Latest revision as of 07:43, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpaceKind returns the object type for texture mapping space.

Table - Texture Mapping Spaces
Date Style Constant
Plane 0
Sphere 1
Cylinder 2
Algorithmic 3
FUNCTION GetTexSpaceKind(
textureSpace :HANDLE) : INTEGER;
def vs.GetTexSpaceKind(textureSpace):
    return INTEGER

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

_c_, (2018.12.29) Use VS:GetTexMapIntN instead.


Returns the kind of the texture mapping space; 0 = Plane space, 1 = Sphere, 2 = Cylinder, and 3 = Algorithmic (Perimeter or Roof)

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0