VS:GetTexSpace2DScale

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpace2DScale returns the 2D scale for the referenced texture space.

FUNCTION GetTexSpace2DScale(
textureSpace :HANDLE) : REAL;
def vs.GetTexSpace2DScale(textureSpace):
    return REAL

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

_c_ (2018 Dec. 29) Use VS:GetTexMapRealN instead.

Gets the 2D scale for this texture space as a multiple of a default size of 1.

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0