VS:GetTexSpace2DRot

From Vectorworks Developer
Revision as of 08:10, 29 December 2017 by CBM-c- (talk | contribs) (add comment)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpace2DRot returns the rotation of the referenced texture space (in degrees).

FUNCTION GetTexSpace2DRot(
textureSpace :HANDLE) : REAL;
def vs.GetTexSpace2DRot(textureSpace):
    return REAL

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

(Orso, 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use VS:GetTexMapRealN instead.


Returns rotation in degrees

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0