VS:GetTexSpace2DRot: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add comment)
(fix)
Line 31: Line 31:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use [[VS:GetTexMapRealN]] instead.
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Use [[VS:GetTexMapRealN]] instead.





Revision as of 10:17, 29 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpace2DRot returns the rotation of the referenced texture space (in degrees).

FUNCTION GetTexSpace2DRot(
textureSpace :HANDLE) : REAL;
def vs.GetTexSpace2DRot(textureSpace):
    return REAL

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

(Orso, 2018 Dec. 29) Use VS:GetTexMapRealN instead.


Returns rotation in degrees

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0