VS:GetTexSpace2DRadius: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(expand info)
Line 31: Line 31:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018.
([[User:Orso.b.schmid|Orso]], 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use [[VS:GetTexMapRealN]] instead.
 


For applicable mapping types, gets the radius of the texture space.
For applicable mapping types, gets the radius of the texture space.

Revision as of 08:10, 29 December 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpace2DRadius returns the radius of the referenced texture space for applicable mapping types.

FUNCTION GetTexSpace2DRadius(
textureSpace :HANDLE) : REAL;
def vs.GetTexSpace2DRadius(textureSpace):
    return REAL

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

(Orso, 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use VS:GetTexMapRealN instead.


For applicable mapping types, gets the radius of the texture space.

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0