VS:GetTexSpace2DOffset

From Vectorworks Developer
Revision as of 08:06, 29 December 2017 by CBM-c- (talk | contribs) (expand info)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexSpace2DOffset returns the 2D offset for the referenced texture space in real-world inches.

PROCEDURE GetTexSpace2DOffset(
textureSpace :HANDLE;
VAR offsetU :REAL;
VAR offsetV :REAL);
def vs.GetTexSpace2DOffset(textureSpace):
    return (offsetU, offsetV)

Parameters

textureSpace HANDLE Handle to texture space.
offsetU REAL Returns texture offset U component.
offsetV REAL returns texture offset V component.

Remarks

(Orso, 2018 Dec. 29) Don't use this: it works but will remove the mapping, tested on VW 2017, 2018. Use VS:GetTexMapRealN instead.

Gets the 2D offset for this texture space in real-world inches.

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0