VS:GetTexMapRealN

From Vectorworks Developer
Revision as of 14:48, 30 December 2017 by CBM-c- (talk | contribs) (add that's mm)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get map info for specific part of object. partID is texture part, overall is 3. Selector: offsetX:1, offsetY:2, scale2D:3, rotate2D:4, radius:5, matrix mat00 through mat32: 6-17

FUNCTION GetTexMapRealN(
obj :HANDLE;
texPartID :LONGINT;
texLayerID :LONGINT;
selector :INTEGER) : REAL;
def vs.GetTexMapRealN(obj, texPartID, texLayerID, selector):
    return REAL

Parameters

obj HANDLE
texPartID LONGINT
texLayerID LONGINT 0 for base, >0 for decals
selector INTEGER

Remarks

(Orso, 2017.12.30):

The radius of a part's texture on a Round Wall can be fetched with the flag 5, it returns mm. GetTexMapRealN(FSActLayer, 7, 0, 5).

Version

Availability: from Vectorworks 2010