VS:GetTexMapRealN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (Transfer Orso to _c_)
 
(2 intermediate revisions by the same user not shown)
Line 46: Line 46:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>[[User:CBM-c-|_c_]] (2017.12.30):
The radius of a part's texture on a Round Wall, fetched with the flag 5, is always mm:
<code lang="vs">
GetTexMapRealN(FSActLayer, 7, 0, 5); { radius in mm of the left part's (7) texture on a round wall }
</code>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 07:48, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get map info for specific part of object. partID is texture part, overall is 3. Selector: offsetX:1, offsetY:2, scale2D:3, rotate2D:4, radius:5, matrix mat00 through mat32: 6-17

FUNCTION GetTexMapRealN(
obj :HANDLE;
texPartID :LONGINT;
texLayerID :LONGINT;
selector :INTEGER) : REAL;
def vs.GetTexMapRealN(obj, texPartID, texLayerID, selector):
    return REAL

Parameters

obj HANDLE
texPartID LONGINT
texLayerID LONGINT 0 for base, >0 for decals
selector INTEGER

Remarks

_c_ (2017.12.30):

The radius of a part's texture on a Round Wall, fetched with the flag 5, is always mm:

GetTexMapRealN(FSActLayer, 7, 0, 5); { radius in mm of the left part's (7) texture on a round wall }

Version

Availability: from Vectorworks 2010