VS:GetTexMapReal

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get map info for specific part of object. partID is texture part, overall is 3.

Selector:

  • offsetX:1
  • offsetY:2
  • scale2D:3
  • rotate2D:4
  • radius:5
  • matrix mat00 through mat32: 6-17
These values are the coefficients for the 4 row x 3 column object space to texture space 3D transform matrix. These values are changed by things like the Edit Mapping dialog.
FUNCTION GetTexMapReal(
h :HANDLE;
partID :LONGINT;
selector :INTEGER) : REAL;
def vs.GetTexMapReal(h, partID, selector):
    return REAL

Parameters

h HANDLE
partID LONGINT texture part, overall is 3.
selector INTEGER offsetX:1, offsetY:2, scale2D:3, rotate2D:4, radius:5, matrix mat00 through mat32: 6-17

Version

Availability: from Vectorworks 14.0. Deprecated from Vectorworks 15.

See Also

* SetTexMapReal VW 14

* [[VS:SetTexMapReal|SetTexMapReal]] VW 14
  • [[VS:SetTexMapRealN|SetTexMapRealN]] from VW 15
  • [[VS:GetTexMapRealN|GetTexMapRealN]] from VW 15