VS:GetTexMapIntN

From Vectorworks Developer
Revision as of 12:24, 29 December 2017 by CBM-c- (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get map info for specific part of object. partID is texture part, overall is 3. Selector should be 1, to return the texture map type integer.

FUNCTION GetTexMapIntN(
obj :HANDLE;
texPartID :LONGINT;
texLayerID :LONGINT;
selector :INTEGER) : INTEGER;
def vs.GetTexMapIntN(obj, texPartID, texLayerID, selector):
    return INTEGER

Parameters

obj HANDLE
texPartID LONGINT
texLayerID LONGINT 0 for base, >0 for decals
selector INTEGER

Remarks

(Orso, 2017 Dec. 29)

Texture Mapping Types:

  • Plane 0
  • Sphere 1
  • Cylinder 2
  • Perimeter 3

If it's set on Auto-align GetTexMapIntN returns the appropriate flag depending on the object

Example

{ Orso: returns the mapping type (plane, sphere, cylinder, perimeter) of the overall texture } GetTexMapIntN(obj, 3, 0, 1);

Version

Availability: from Vectorworks 2010