VS:GetTexBitmapOrigin

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexBitmapOrigin returns the origin of the bitmap applied to the referenced texture bitmap. The origin is measured in pixels, with the top left corner as (0,0).

PROCEDURE GetTexBitmapOrigin(
textureBitmap :HANDLE;
VAR originX :INTEGER;
VAR originY :INTEGER);
def vs.GetTexBitmapOrigin(textureBitmap):
    return (originX, originY)

Parameters

textureBitmap HANDLE Handle to texture bitmap.
originX INTEGER Returns X coordinate of bitmap origin.
originY INTEGER Returns Y coordinate of bitmap origin.

Remarks

Origin x and y are in pixels from paint node top left

Version

GetTexBitmapOrigin is obsolete as of VectorWorks9.0


Availability: from VectorWorks8.0