VS:GetTexBFeatureStart

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexBFeatureStart returns the "feature startpoint" of the referenced texture bitmap. The point is expressed in pixels from the top left corner of the bitmap.

PROCEDURE GetTexBFeatureStart(
textureBitmap :HANDLE;
VAR featureStartX :INTEGER;
VAR featureStartY :INTEGER);
def vs.GetTexBFeatureStart(textureBitmap):
    return (featureStartX, featureStartY)

Parameters

textureBitmap HANDLE Handle to texture bitmap.
featureStartX INTEGER Returns X coordinate of feature start point.
featureStartY INTEGER Returns Y coordinate of feature start point.

Remarks

X and y are in paint node pixels from top left

Version

Availability: from VectorWorks8.0