VS:GetSymbolType

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines the type of the specified symbol instance. The return values are:

0 - 2D Only 1 - 3D Only 2 - Hybrid

FUNCTION GetSymbolType(
objectHandle :HANDLE) : INTEGER;
def vs.GetSymbolType(objectHandle):
    return INTEGER

Parameters

objectHandle HANDLE Handle to a symbol instance.

Return Value

-1 = error. Possibly wrong type of object passed in.

0 = 2D Symbol 1 = 3D Symbol 2 = Hybrid Symbol

Version

Availability: from VectorWorks10.0