VS:GetSymbolType

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines the type of the specified symbol instance. The return values are:

0 - 2D Only 1 - 3D Only 2 - Hybrid

FUNCTION GetSymbolType(
objectHandle :HANDLE) : INTEGER;
def vs.GetSymbolType(objectHandle):
    return INTEGER

Parameters

objectHandle HANDLE Handle to a symbol instance.

Return Value

-1 = error. Possibly wrong type of object passed in.

0 = 2D Symbol 1 = 3D Symbol 2 = Hybrid Symbol

Version

Availability: from VectorWorks10.0