VS:GetSymbolType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines the type of the specified symbol instance. The return values are:

0 - 2D Only 1 - 3D Only 2 - Hybrid

FUNCTION GetSymbolType(
objectHandle :HANDLE) : INTEGER;
def vs.GetSymbolType(objectHandle):
    return INTEGER

Parameters

objectHandle HANDLE Handle to a symbol instance.

Return Value

-1 = error. Possibly wrong type of object passed in.

0 = 2D Symbol 1 = 3D Symbol 2 = Hybrid Symbol

Version

Availability: from VectorWorks10.0