VS:GetSymbolOptions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 09:39, 3 February 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetSymbolOptions returns the insert and break options for the specified symbol.


Table - Symbol Insertion Options

Insertion Mode Description Constant Value
Insert on Center Line 0
Insert on Edge 1
Break Mode Description Constant Value
Full Break with Caps 1
Full Break No Caps 2
Half Break 3
No Break 4
PROCEDURE GetSymbolOptions(
name :STRING;
VAR insertMode :INTEGER;
VAR breakMode :INTEGER);
def vs.GetSymbolOptions(name):
    return (insertMode, breakMode)

Parameters

name STRING Name of symbol.
insertMode INTEGER Returns insertion mode of symbol.
breakMode INTEGER Returns break mode of inserted symbol.

Remarks

Deleted this obsolete function as of 9.0.0b7 - PCP 12-21-2000


Gets the insertion options from the master symbol named <name>.

See SetSymbolOptions.

[8/18/98]

Version

GetSymbolOptions is obsolete as of VectorWorks8.5


Availability: from VectorWorks8.0