VS:GetStoryOfLayer: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the Story that the indicated Layer is associated with. Returns NULL if the Layer is not associated with a Story.

FUNCTION GetStoryOfLayer(
layer :HANDLE) : HANDLE;
def vs.GetStoryOfLayer(layer):
    return HANDLE

Parameters

layer HANDLE The Layer for which the associated Story is returned.

Return Value

The Story associated with the Layer, which may be NULL.

Example

VAR

story:HANDLE;

BEGIN

story:=GetStoryOfLayer(ActLayer);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetLayerForStory | VS:GetNumStories | VS:CreateStory | VS:AssociateLayerWithStory

VS Functions:

[[VS:GetLayerForStory]] | [[VS:GetNumStories]] | [[VS:CreateStory]]

| [[VS:AssociateLayerWithStory]]