VS:GetStoryLayerTemplateName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the name of the nth Story Layer Template in the file. For example, if 3 is passed in, it will return the name of the 3rd Story Layer Template in the file.

FUNCTION GetStoryLayerTemplateName(
index :INTEGER) : STRING;
def vs.GetStoryLayerTemplateName(index):
    return STRING

Parameters

index INTEGER The index of the Story Layer Template whose name is desired.

Return Value

The name of the nth Story Layer Template.

Example

VAR

templateName:STRING;

BEGIN

templateName:=GetStoryLayerTemplateName(2);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetNumStoryLayerTemplates | VS:CreateStoryLayerTemplate

VS Functions:

[[VS:GetNumStoryLayerTemplates]]

| [[VS:CreateStoryLayerTemplate]]