VS:GetStoryLayerInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns information on the given story layer template

FUNCTION GetStoryLayerInfo(
index :INTEGER;
VAR name :STRING;
VAR scaleFactor :REAL;
VAR layerLevelType :STRING;
VAR eleveationOffset :REAL;
VAR defaultWallHeight :REAL) : Boolean;
def vs.GetStoryLayerInfo(index):
    return (Boolean, name, scaleFactor, layerLevelType, eleveationOffset, defaultWallHeight)

Parameters

index INTEGER Index of story.
name STRING Returns with Name of story layer template
scaleFactor REAL Returns with Scale Factor of story layer template
layerLevelType STRING Returns with Level Type of story layer template
eleveationOffset REAL Returns with the Elevation Offset of story layer template
defaultWallHeight REAL Returns with the Default Wall Height of story layer template

Return Value

Boolean - TRUE if the story at given index was found, FALSE if no story was found at the given index.

Version

Availability: from Vectorworks 2012