VS:GetStoryChoiceStrsN

From Vectorworks Developer
Revision as of 18:50, 7 December 2020 by Unknown user
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets story bound strings to supply to the bound popup. Can request strings for top bound, bottom bound, or dual (both) bounds.

PROCEDURE GetStoryChoiceStrsN(
story :HANDLE;
VAR strings :ARRAY;
boundSelection :INTEGER);
def vs.GetStoryChoiceStrsN(story, boundSelection):
    return strings

Parameters

story HANDLE The story relative to which to get the strings. Nil gets a generic list of strings.
strings ARRAY Returns the strings.
boundSelection INTEGER Type of bounds strings being requested: 0 for Top Bound; 1 for Dual Bound (combines both top and bottom); 2 for Bottom Bound.

Version

Availability: from Vectorworks 2017