VS:GetStoryBoundChoiceStrings

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the choice strings for a story bound control.

PROCEDURE GetStoryBoundChoiceStrings(
story :HANDLE;
topBound :BOOLEAN;
VAR strings :ARRAY);
def vs.GetStoryBoundChoiceStrings(story, topBound):
    return strings

Parameters

story HANDLE The story relative to which to get the strings. Nil gets a generic list of strings.
topBound BOOLEAN Whether to get the strings for a top bound or a bottom bound.
strings ARRAY Returns the strings.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetStoryBoundDataFromChoiceString | VS:GetChoiceStringFromStoryBoundData

VS Functions:

[[VS:GetStoryBoundDataFromChoiceString]]

| [[VS:GetChoiceStringFromStoryBoundData]]