VS:GetStoryAbove

From Vectorworks Developer
Revision as of 17:43, 20 September 2011 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the Story above the indicated Story. Returns NULL if there is none. If passed a NULL handle, returns the top-most Story in the current drawing.

FUNCTION GetStoryAbove(
story :HANDLE) : HANDLE;
def vs.GetStoryAbove(story):
    return HANDLE

Parameters

story HANDLE The indicated Story for which the Story above it is desired.

Return Value

The Story above the indicated Story, or NULL if there is none. If a NULL handle is passed in, the topmost Story in the current drawing.

Example

VAR

baseStory:HANDLE;
storyAbove:HANDLE;

BEGIN

baseStory := GetStoryOfLayer(ActLayer);
storyAbove := StoryAbove(baseStory);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetStoryBelow | VS:GetNumStories | VS:GetStoryOfLayer

VS Functions:

[[VS:GetStoryBelow]] | [[VS:GetNumStories]]

| [[VS:GetStoryOfLayer]]