VS:GetSingularConstraint

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the type of constraint applied to the referenced object.

Table - Constraint Types
Index Constraint Type
4 Vertical
5 Horizontal
8 Distance
9 Vertical distance
10 Horizontal distance
11 Radius
FUNCTION GetSingularConstraint(
typeOfConstraint :INTEGER;
obj :HANDLE;
vertexA :INTEGER;
vertexB :INTEGER) : HANDLE;
def vs.GetSingularConstraint(typeOfConstraint, obj, vertexA, vertexB):
    return HANDLE

Parameters

typeOfConstraint INTEGER Type of constraint to be returned.
obj HANDLE Handle to object.
vertexA INTEGER Vertex defining the constraint geometry.
vertexB INTEGER Vertex defining the constraint geometry.

Return Value

Returns a HANDLE to the constraint if exists, otherwise returns NIL.

Version

Availability: from VectorWorks 9.0