VS:GetShaderRecord

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the shader record of the specified family (1 = color, 2 = reflectivity, 3 = transparency, 4 = bump), if one is attached to the texture.

FUNCTION GetShaderRecord(
texture :HANDLE;
family :LONGINT) : HANDLE;
def vs.GetShaderRecord(texture, family):
    return HANDLE

Parameters

texture HANDLE Get the shader record attached to this texture.
family LONGINT The kind of shader to retrieve (1 = color, 2 = reflectivity, 3 = transparency, 4 = bump).

Version

Availability: from VectorWorks10.1