VS:GetSelectionRange

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the range of the current selection for the specified control.

PROCEDURE GetSelectionRange(
dialogID :LONGINT;
controlID :LONGINT;
VAR startPos :INTEGER;
VAR endPos :INTEGER);
def vs.GetSelectionRange(dialogID, controlID):
    return (startPos, endPos)

Parameters

dialogID LONGINT
controlID LONGINT
startPos INTEGER
endPos INTEGER

Version

Availability: from VectorWorks12.0.1