VS:GetSelectedChoiceIndex

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the index of the selected choice.

PROCEDURE GetSelectedChoiceIndex(
dialogID :LONGINT;
componentID :LONGINT;
startIndex :INTEGER;
VAR outSelectedIndex :INTEGER);
def vs.GetSelectedChoiceIndex(dialogID, componentID, startIndex):
    return outSelectedIndex

Parameters

dialogID LONGINT The dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier for the component that contains the choices.
startIndex INTEGER The index at which to start looking for a selected item.
outSelectedIndex INTEGER The index of the selected item or -1 if there is no selected item.

Version

Availability: from Vectorworks 2010