VS:GetSelectedChoiceIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
mNo edit summary
 
(One intermediate revision by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Gets the index of the selected choice.</desc>
Gets the 0-based index of the selected choice.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 17:00, 16 April 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the 0-based index of the selected choice.

PROCEDURE GetSelectedChoiceIndex(
dialogID :LONGINT;
componentID :LONGINT;
startIndex :INTEGER;
VAR outSelectedIndex :INTEGER);
def vs.GetSelectedChoiceIndex(dialogID, componentID, startIndex):
    return outSelectedIndex

Parameters

dialogID LONGINT The dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier for the component that contains the choices.
startIndex INTEGER The index at which to start looking for a selected item.
outSelectedIndex INTEGER The index of the selected item or -1 if there is no selected item.

Version

Availability: from Vectorworks 2010