VS:GetRoofFaceCoords/ja

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根の傾きを取得します。

PROCEDURE GetRoofFaceCoords(
h :HANDLE;
VAR axis1 :REAL;
VAR axis2 :REAL;
VAR Zaxis :REAL;
VAR upslope :REAL);
def vs.GetRoofFaceCoords(h):
    return (axis1, axis2, Zaxis, upslope)

Parameters

h HANDLE 屋根のハンドル
axis1 REAL 最初の軸の座標
axis2 REAL 2番目の軸の座標
Zaxis REAL 高さ
upslope REAL X軸、Y軸のスロープ距離

Example

PROCEDURE GetRoofFaceCoordsExample;

PROCEDURE MarkCoords(h :HANDLE);
VAR
	beg_pt, end_pt, upslope_pt :VECTOR;
	Z :REAL;
BEGIN
	IF GetObjectVariableInt(h, 172) = 1 THEN BEGIN
		GetRoofFaceCoords(h, beg_pt.x, beg_pt.y, end_pt.x, end_pt.y, Z, upslope_pt.x, upslope_pt.y);
		beg_pt     := beg_pt     * (25.4 / GetPrefReal(152));
		end_pt     := end_pt     * (25.4 / GetPrefReal(152));
		upslope_pt := upslope_pt * (25.4 / GetPrefReal(152));
		Locus(beg_pt.x, beg_pt.y);
		Locus(end_pt.x, end_pt.y);
		Locus(upslope_pt.x, upslope_pt.y);
	END;
END;

BEGIN
	ForEachObject(MarkCoords, (T=71));
END;
RUN(GetRoofFaceCoordsExample);

Version

利用可能バージョン: VectorWorks9.0