VS:GetRoofEdge

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetRoofEdge returns the definition attributes of a roof edge for the referenced roof object.

FUNCTION GetRoofEdge(
theRoof :HANDLE;
index :INTEGER;
VAR vertexPtX,vertexPtY :REAL;
VAR slope :REAL;
VAR projection :REAL;
VAR eaveHeight :REAL) : BOOLEAN;
def vs.GetRoofEdge(theRoof, index):
    return (BOOLEAN, vertexPt, slope, projection, eaveHeight)

Parameters

theRoof HANDLE Handle to roof.
index INTEGER Index of roof edge (in a range of 1 - n).
vertexPt REAL Returns coordinates of roof edge definition vertex.
slope REAL Returns slope of roof edge.
projection REAL Retunrs eave overhang dimension.
eaveHeight REAL Returns eave height.

Remarks

Vertices define the outline of the roof and its characteristics. Vertices must progress in a counter clock wise direction, when viewed from a top view, otherwise the roof cannot be built.

index: Indexs have values between 1 and NVertices (See GetRoofVertices()) edgePt: Coordinate point for this edge slope: pitch of this roof edge projection: eave overhang eaveHeight: eave height

Version

Availability: from VectorWorks8.0