VS:GetRoofAttributes/ja

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根の情報を返します。

FUNCTION GetRoofAttributes(
theRoof :HANDLE;
VAR genGableWall :BOOLEAN;
VAR bearingInset :REAL;
VAR roofThick :REAL;
VAR miterType :INTEGER;
VAR vertMiter :REAL) : BOOLEAN;
def vs.GetRoofAttributes(theRoof):
    return (BOOLEAN, genGableWall, bearingInset, roofThick, miterType, vertMiter)

Parameters

theRoof HANDLE 屋根のハンドル
genGableWall BOOLEAN 切り妻の有無
bearingInset REAL 壁からの距離
roofThick REAL 屋根の厚み
miterType INTEGER 切り妻の種類
vertMiter REAL 切り妻の高さ

Example

PROCEDURE Example;
var
	theRoof :HANDLE;
	genGableWall :BOOLEAN; 
	bearingInset, roofThick :REAL; 
	miterType :INTEGER; 
	vertMiter :REAL;
begin
	theRoof := FSActLayer;
	IF GetRoofAttributes(theRoof, genGableWall, bearingInset, roofThick, miterType, vertMiter)
	THEN Message(genGableWall, ' ', bearingInset, ' ', roofThick, ' ', miterType, ' ', vertMiter);
end;
RUN(Example);

Version

利用可能バージョン: VectorWorks8.0