VS:GetResourceTags: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(expand a bit about the used array)
Line 36: Line 36:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2017.02.26): The array to be used is an ARRAY[] OF STRING. The Array can be probably sized up to integer limit 32767 but don't do it: large arrays cause a really heavy delay upon any human or script action on the involved resource, such as attempts to select it in the Resource Manager.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:36, 26 February 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the tags attached to the specified resource.

PROCEDURE GetResourceTags(
handle :HANDLE;
VAR tags :ARRAY);
def vs.GetResourceTags(handle):
    return tags

Parameters

handle HANDLE The handle to the resource.
tags ARRAY The list of tags.

Remarks

(Orso, 2017.02.26): The array to be used is an ARRAY[] OF STRING. The Array can be probably sized up to integer limit 32767 but don't do it: large arrays cause a really heavy delay upon any human or script action on the involved resource, such as attempts to select it in the Resource Manager.

Version

Availability: from Vectorworks 2017

See Also

VS Functions:

VS:SetResourceTags | VS:GetNumResourceTags

VS Functions:

[[VS:SetResourceTags]]

| [[VS:GetNumResourceTags]]