VS:GetResourceString: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
<b>Deprecated since Vectorworks 2015</b>: Use [[VS:GetVWRString]] instead.
<br>
Returns the specified resource string from a resource file.</desc>
Returns the specified resource string from a resource file.</desc>


Line 43: Line 46:
<seeAlso>
<seeAlso>
VS Functions:
VS Functions:
[[VS:GetVWRString]] ,
[[VS:SetVSResourceFile]]  
[[VS:SetVSResourceFile]]  
</seeAlso>
</seeAlso>
Line 48: Line 52:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks9.0
Availability: from VectorWorks 9.0
 
<b>Deprecated since Vectorworks 2015</b>: Use [[VS:GetVWRString]] instead.
</version>
</version>



Latest revision as of 12:52, 23 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deprecated since Vectorworks 2015: Use VS:GetVWRString instead.


Returns the specified resource string from a resource file.

PROCEDURE GetResourceString(
VAR theString :STRING;
id :INTEGER;
index :INTEGER);
def vs.GetResourceString(id, index):
    return theString

Parameters

theString STRING The string contained within the resource.
id INTEGER The ID of the resource.
index INTEGER The index of the string resource.

Version

Availability: from VectorWorks 9.0

Deprecated since Vectorworks 2015: Use VS:GetVWRString instead.

See Also

VS Functions:

VS:GetVWRString , VS:SetVSResourceFile

VS Functions:

[[VS:GetVWRString]] ,

[[VS:SetVSResourceFile]]