VS:GetRect: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 13: Line 13:
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetRect():
def vs.GetRect(callback):
     return (p1, p2)
     return None
</funcDef>
</funcDef>
</def>
</def>
Line 34: Line 34:
</params>
</params>


-----------------------------------------------------------------------------------------------------------
<remark>
In Python this function will <b>NOT</b> block execution. It will execute a callback function with the resulted rectangle (two points as callback function parameters).</remark>
-----------------------------------------------------------------------------------------------------------
<sample>
Python sample is similar to the sample in [[VS:GetPt]].
</sample>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>

Latest revision as of 19:20, 20 December 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetRect draws a temporary "rubberband" rectangle onscreen, similar to a selection marquee. The user defines the rectangle by selecting two points which define the top left and bottom right of the rectangle. This cannot be used if there is a function anywhere in the calling chain.

PROCEDURE GetRect(
VAR p1X,p1Y :REAL;
VAR p2X,p2Y :REAL);
def vs.GetRect(callback):
    return None

Parameters

p1 REAL Returns coordinates of first user click.
p2 REAL Returns coordinates of second user click.

Remarks

In Python this function will NOT block execution. It will execute a callback function with the resulted rectangle (two points as callback function parameters).

Example

Python sample is similar to the sample in VS:GetPt.

Version

Availability: from All Versions

See Also

VS Functions:

VS:GetPt | VS:GetPtL | VS:GetPt3D | VS:GetPtL3D | VS:GetLine | VS:GetLine3D | VS:GetRect | VS:GetRect3D | VS:TrackObject

VS Functions:

[[VS:GetPt]] | [[VS:GetPtL]] | [[VS:GetPt3D]] | [[VS:GetPtL3D]] | [[VS:GetLine]] | [[VS:GetLine3D]] | [[VS:GetRect]] | [[VS:GetRect3D]] |

[[VS:TrackObject]]