VS:GetRecord

From Vectorworks Developer
Revision as of 06:29, 30 December 2020 by CBM-c- (talk | contribs) (Transfer Orso to _c_)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the handle to a specified record attached the referenced object.

FUNCTION GetRecord(
h :HANDLE;
cnt :INTEGER) : HANDLE;
def vs.GetRecord(h, cnt):
    return HANDLE

Parameters

h HANDLE Handle to object.
cnt INTEGER Index of attached record (in a range of 1 - n).

Remarks

_c_, 2015.02.24:

Please note that since the introduction of ifc data, the usual praxis of fetching plug-in records using GetRecord(h, NumRecords(h)) can bring you perhaps unexpectedly the ifc record. Use VS:GetParametricRecord instead, introduced from VW 2011.

Example

VectorScript

handleToRecord := GetRecord(handleToObject,3);

Python

handleToRecord = vs.GetRecord(handleToObject,3)

Version

Availability: from All Versions