VS:GetRecord: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 33: Line 33:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
[[User:CBM-c-|_c_]], 2015.02.24:
Please note that since the introduction of ifc data, the usual praxis of fetching plug-in records using GetRecord(h, NumRecords(h)) can bring you perhaps unexpectedly the ifc record. Use [[VS:GetParametricRecord]] instead, introduced from VW 2011.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 06:29, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the handle to a specified record attached the referenced object.

FUNCTION GetRecord(
h :HANDLE;
cnt :INTEGER) : HANDLE;
def vs.GetRecord(h, cnt):
    return HANDLE

Parameters

h HANDLE Handle to object.
cnt INTEGER Index of attached record (in a range of 1 - n).

Remarks

_c_, 2015.02.24:

Please note that since the introduction of ifc data, the usual praxis of fetching plug-in records using GetRecord(h, NumRecords(h)) can bring you perhaps unexpectedly the ifc record. Use VS:GetParametricRecord instead, introduced from VW 2011.

Example

VectorScript

handleToRecord := GetRecord(handleToObject,3);

Python

handleToRecord = vs.GetRecord(handleToObject,3)

Version

Availability: from All Versions