VS:GetRFieldOpt

From Vectorworks Developer
Revision as of 15:47, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the options for a record field.

PROCEDURE GetRFieldOpt(
h :HANDLE;
record :STRING;
field :STRING;
VAR outIsEmpty :BOOLEAN;
VAR outIsDataLinked :BOOLEAN);
def vs.GetRFieldOpt(h, record, field):
    return (outIsEmpty, outIsDataLinked)

Parameters

h HANDLE Handle to object.
record STRING Name of record format.
field STRING Name of field to be queried.
outIsEmpty BOOLEAN Output the flag for empty value used by the Data Manager.
outIsDataLinked BOOLEAN Output the flag for data linked value used by the Data Manager.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:SetRFieldOpt | VS:GetRField | VS:SetRField

VS Functions:

[[VS:SetRFieldOpt]] | [[VS:GetRField]]

| [[VS:SetRField]]