VS:GetRFieldOpt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:47, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the options for a record field.

PROCEDURE GetRFieldOpt(
h :HANDLE;
record :STRING;
field :STRING;
VAR outIsEmpty :BOOLEAN;
VAR outIsDataLinked :BOOLEAN);
def vs.GetRFieldOpt(h, record, field):
    return (outIsEmpty, outIsDataLinked)

Parameters

h HANDLE Handle to object.
record STRING Name of record format.
field STRING Name of field to be queried.
outIsEmpty BOOLEAN Output the flag for empty value used by the Data Manager.
outIsDataLinked BOOLEAN Output the flag for data linked value used by the Data Manager.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:SetRFieldOpt | VS:GetRField | VS:SetRField

VS Functions:

[[VS:SetRFieldOpt]] | [[VS:GetRField]]

| [[VS:SetRField]]