VS:GetPt3D

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetPt3D switches the cursor to 3D selection mode and allows the user to select a point in a VectorWorks document. This cannot be used if there is a function anywhere in the calling chain.

PROCEDURE GetPt3D(
VAR pX, pY, pZ :REAL;
useWPOnly :BOOLEAN);
def vs.GetPt3D(useWPOnly):
    return p

Parameters

pX, pY, pZ REAL Returns coordinates of mouse click.
useWPOnly BOOLEAN TRUE if the returned point have to be on the active Working Plane. Snapping to arbitrary 3D geometry will produce vertical projection result on the WP; FALSE if the point can be arbitrary 3D point (produced, for example, by snapping to a 3D geometry)

Remarks

(Orso, 2011 Jan. 09) the z-value of the returned 3D point is always zero if

  • the current view is Top-plan or Top (From Raymond Mullin).
  • there is no pre-existing snapped geometry in 3D (by useWPOnly = FALSE)

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:GetPt | VS:GetPtL | VS:GetPt3D | VS:GetPtL3D | VS:GetLine | VS:GetLine3D | VS:GetRect | VS:GetRect3D | VS:TrackObject

VS Functions:

[[VS:GetPt]] | [[VS:GetPtL]] | [[VS:GetPt3D]] | [[VS:GetPtL3D]] | [[VS:GetLine]] | [[VS:GetLine3D]] | [[VS:GetRect]] | [[VS:GetRect3D]] |

[[VS:TrackObject]]