VS:GetPt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 41: Line 41:
END;
END;
RUN(Example);</code>
RUN(Example);</code>
Python:
<code lang="py">
import vs;
def DoIt(h1):
vs.AlrtDialog( "we're in", h1 )
def PickPointCallback(pt):
vs.ForEachObjectAtPoint(DoIt, 0, 0, pt[0], pt[1], 5)
vs.AlrtDialog( "show let you pick a point, and then show a dialog with the object's handle" )
vs.GetPt( PickPointCallback )
</code>
</sample>
</sample>



Revision as of 19:09, 20 December 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetPt switches the cursor to selection mode and allows the user to select a point in a VectorWorks document. This cannot be used if there is a function anywhere in the calling chain.

PROCEDURE GetPt(
VAR pX,pY :REAL);
def vs.GetPt():
    return p

Parameters

p REAL Returns coordinates of mouse click.

Example

PROCEDURE Example;
VAR
pt :POINT;
BEGIN
GetPt(pt.x, pt.y);
Message(pt);
END;
RUN(Example);

Python:

import vs;

def DoIt(h1):
	vs.AlrtDialog( "we're in", h1 )

def PickPointCallback(pt):
	vs.ForEachObjectAtPoint(DoIt, 0, 0, pt[0], pt[1], 5)

vs.AlrtDialog( "show let you pick a point, and then show a dialog with the object's handle" )
vs.GetPt( PickPointCallback )

Version

Availability: from All Versions

See Also

VS Functions:

VS:GetPt | VS:GetPtL | VS:GetPt3D | VS:GetPtL3D | VS:GetLine | VS:GetLine3D | VS:GetRect | VS:GetRect3D | VS:TrackObject

VS Functions:

[[VS:GetPt]] | [[VS:GetPtL]] | [[VS:GetPt3D]] | [[VS:GetPtL3D]] | [[VS:GetLine]] | [[VS:GetLine3D]] | [[VS:GetRect]] | [[VS:GetRect3D]] |

[[VS:TrackObject]]