VS:GetProjection

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the projection index from the specified layer.

FUNCTION GetProjection(
theyLayer :HANDLE) : INTEGER;
def vs.GetProjection(theyLayer):
    return INTEGER

Parameters

theyLayer HANDLE Layer which the projection is returned for.

Return Value

Projection values:

  • 0: kOrthogonal
  • 1: kPerspective
  • 2: kCavalierOblique45
  • 3: kCavalierOblique30
  • 4: kCabinetOblique45
  • 5: kCabinetOblique30
  • 6: kPlan

Version

Availability: from VectorWorks13.0

See Also

VS:ActLayer

[[VS:ActLayer]]