VS:GetProjectUser: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 17:43, 16 September 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

For a given userid in the current Project, get their full name and permission level.


Table - Project Sharing Permissions

Permission Level> Constant
Read Only 1
Layers-Restricted 2
Layers-Unrestricted 3
Layers and Resources 4
Project 5
Administrative 6
FUNCTION GetProjectUser(
userId :STRING;
VAR fullName :STRING;
VAR permission :INTEGER) : BOOLEAN;
def vs.GetProjectUser(userId):
    return (BOOLEAN, fullName, permission)

Parameters

userId STRING The userid to look up
fullName STRING The users full name
permission INTEGER Permission level of the user

Return Value

True on success, false on failure or not Project Sharing file.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetProjectUserNames

VS Functions: [[VS:GetProjectUserNames]]