VS:GetProduct

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Identifies what NNA products and product packages are available in the current product installation.

Obsolete as of 10. Use GetEnabledModules instead.

PROCEDURE GetProduct(
VAR product :INTEGER;
VAR modules :LONGINT);
def vs.GetProduct():
    return (product, modules)

Parameters

product INTEGER Product index.
modules LONGINT Package index.

Remarks

Retrieves information that identifies what vertical market product (if any) is currently running, and which add-ons (modules) are currently available (if any).


Should mark this as obsolete.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetEnabledModules

VS Functions: [[VS:GetEnabledModules]]