VS:GetPrefString

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a VectorWorks preference setting. Used with preference settings returning a STRING value.

A table of preference dialog items and their corresponding IDs may be found in the Appendix.

FUNCTION GetPrefString(
prefIndex :INTEGER) : STRING;
def vs.GetPrefString(prefIndex):
    return STRING

Parameters

prefIndex INTEGER Preference item index.

Return Value

Returns the value of the specified preference.

Remarks

Returns the status of the specified preference item. Used for preferences that return a string instead of a Boolean (see GetPref)

Example

VectorScript

unitmark:=GetPrefString(154);

Python

unitmark = vs.GetPrefString(154)

Version

Availability: from VectorWorks9.0