VS:GetPrefReal

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a VectorWorks preference setting. Used with preference settings returning a REAL value.

A table of preference dialog items and their corresponding IDs may be found in the Appendix.

FUNCTION GetPrefReal(
prefIndex :INTEGER) : REAL;
def vs.GetPrefReal(prefIndex):
    return REAL

Parameters

prefIndex INTEGER Preference item index.

Return Value

Returns the value of the specified preference.

Remarks

Returns the status of the specified preference item. Used for preferences that return a real instead of a Boolean (see GetPref)

Example

VectorScript

upi:= GetPrefReal(152);

Python

upi = vs.GetPrefReal(152)

Version

Availability: from VectorWorks9.0