VS:GetPrefLongInt

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of a VectorWorks preference setting. Used with preference settings returning a LONGINT value.

A table of preference dialog items and their corresponding IDs may be found in the Appendix.

FUNCTION GetPrefLongInt(
prefIndex :INTEGER) : LONGINT;
def vs.GetPrefLongInt(prefIndex):
    return LONGINT

Parameters

prefIndex INTEGER Preference item index.

Return Value

Returns the value of the specified preference.

Remarks

Returns the status of the specified preference item. Used for preferences that return a long integer instead of a Boolean (see GetPref)

The status of the requested preference. If the preference is a checkbox, then GetPrefLongInt returns TRUE or false. If it is a radio group or editable text item, then GetPrefLongInt returns an integer value representing that setting.

Example

VectorScript

convertRes2D:= GetPrefLongInt(55);

Python

convertRes2D = vs.GetPrefLongInt(55)

Version

Availability: from VectorWorks9.0