VS:GetPrefInt

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetPrefInt returns the value of a numeric VectorWorks preference setting.

A table of preference dialog items and their corresponding IDs may be found in the Appendix.

FUNCTION GetPrefInt(
prefIndex :INTEGER) : INTEGER;
def vs.GetPrefInt(prefIndex):
    return INTEGER

Parameters

prefIndex INTEGER Preference item constant.

Return Value

The status of the requested preference. If the preference is a checkbox, then GetPrefInt returns TRUE or false. If it is a radio group or editable text item, then GetPrefInt returns an integer value representing that setting.

Remarks

Returns the status of the specified preference item. Used for preferences that return an Integer instead of a Boolean (see GetPref)

Example

VectorScript

maxUndos:=GetPrefInt(17);

Python

maxUndos = vs.GetPrefInt(17)

Version

Availability: from VectorWorks8.0